准确率80% 可做小波段的通道顶底 通达信主图指标 更多金钻指标免费QQ群:423987308
{通道顶底}

VAR11:=MA(C,9),COLORRED;
上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORRED;
下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;
A0:=(L+H+C*2)/4;
AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;
BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;
A1X:=(AA-REF(AA,1))/REF(AA,1)*100;
A2X:=(BB-REF(BB,1))/REF(BB,1)*100;
G:=BARSLAST(CROSS(A1X,0));
必卖止损:REF(A0,G),COLORCYAN,LINETHICK1;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
见底:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
见顶:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,DRAWNULL),COLORGREEN,CIRCLEDOT;
MA5:=MA(C,5);
N:=80; {参数}
M:=3; {参数}
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORRED;
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,0);
STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,4,0),COLORRED;
STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,4,0),COLORBLUE;
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,4,0),COLORRED;
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,4,0),COLORBLUE;
STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORRED;{涨停后回落}
STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORBLUE;{跌停后回升}
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;
DRAWTEXT_FIX(1,0.00,0.38,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.06,0.38,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.46,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.06,0.46,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0,2,0,EXTERNSTR(0,1))COLOR00FF00;
DRAWTEXT_FIX(ISLASTBAR,0.9,0.1,0,HYBLOCK),COLOREE8FFF;
DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,DYBLOCK),COLOREE8FFF;
DRAWTEXT_FIX(1,0.00,0.88,0,'概念:')COLORFF00FF;
N0:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y:=STRCAT(CON2STR(MONTH,0),' 月 ');
R:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ:=STRCAT(STRCAT(N0,Y), R);
DRAWTEXT_FIX(C>0,0.48,0,0,SJ);
DRAWTEXT_FIX(ISLASTBAR,0.65,0.05,0,CODE),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.75,0.05,0,STKNAME)COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.9,0.1,0,HYBLOCK),COLOREE8FFF;
DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,DYBLOCK),COLOREE8FFF;
TM:=1200823;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),ZTPRICE(REF(C,1),IF(FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),DTPRICE(REF(C,1),IF(FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:IF(DATE<TM,C*IF(FINANCE(3)=4,1.2,IF(NAMEINCLUDE('S'),1.05,1.1)),C*(FINANCE(3)>2,1.2,IF(NAMEINCLUDE('S'),1.05,1.1))),NODRAW,COLORLIMAGENTA;
明跌停:IF(DATE<TM,C*IF(FINANCE(3)=4,0.8,IF(NAMEINCLUDE('S'),0.45,0.9)),C*(FINANCE(3)>2,0.8,IF(NAMEINCLUDE('S'),0.45,0.9))),NODRAW,COLORFFFF00;
ZT:=C>=IF(DATE<TM,ZTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),ZTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))));
DT:=C<=IF(DATE<TM,DTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),DTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))));
ZT1:=H>=IF(DATE<TM,ZTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),ZTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1)))) AND H>C;
DT1:=L<=IF(DATE<TM,DTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),DTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE('S'),0.05,0.1)))) AND L<C;
STICKLINE(ZT,C,O,3,0),COLORRED;
STICKLINE(DT,C,O,3,0),COLORLIGREEN;
STICKLINE(ZT1,C,O,3,0),COLORFF00FF;
STICKLINE(DT1,C,O,3,0),COLOR00FF99;
流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
DRAWTEXT_FIX(1,0.00,0.9,0,'{资金诊断}1、乖离系数,大于40关注 小于-50坚决不进场 ,大于60坚决买入,2、控盘系数大于20 可以做个小波段 准确率80%。'),COLORGREEN,LINETHICK1;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
PVAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
布林上轨:=MA(CLOSE,24)+2*STD(CLOSE,24);
{}
WMA5:=MA(C,5);
XJJ:=MA(C,5)>REF(MA(C,5),1) AND 布林上轨>REF(布林上轨,1) AND 布林上轨/MA(C,5)<1.07
AND O<布林上轨 AND C>布林上轨 AND C/REF(C,1)>1.031;
极速线:=MA(C,25)+MA(C,25)*20/100;
WXG1:=XJJ AND C>极速线;
WXG2:=O<MA(C,5) AND XJJ AND C<极速线;
XGLL:=WXG1 OR WXG2;
XGPP:=XGLL AND NOT(REF(XGLL,1));
DRAWTEXT(XGPP,H*1.01,'加速'),COLORRED;
{M:=88;N1:=6;}
VAR0A:=EMA(EMA(EMA(CLOSE,2),2),2);
MA13:=(MA(VAR0A,13)*0.99);
TLAMSENR:=MAX(MAX((HIGH-LOW),ABS((REF(CLOSE,1)-HIGH))),ABS((REF(CLOSE,1)-LOW)));
ATR:=MA(TLAMSENR,13);
VAR1AL:=(REF(CLOSE,1)-REF(ATR,1));
平台线:(HHV(VAR1AL,12)),LINETHICK2,COLORGREEN;
选股票看什么指标最好 >股票指标网