通达信跟庄进场主图指标
更多金钻指标免费QQ群:39652085 指标改选股QQ群:220302856
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,COLORFF7700;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
{长期趋势线}
{长期趋势线:(MA(C,188)),COLORGREEN,LINETHICK2;
LC:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
起步:IF((RS1 >58),长期趋势线,DRAWNULL),,COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,长期趋势线,' 长期')COLORYELLOW;}
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
短线趋势线:VAR1,COLORWHITE;
中线趋势线:VAR6,COLORYELLOW,LINETHICK3;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORFF5500,LINETHICK4;
BIAS13:=MA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13),3)*100,COLORFF5500,LINETHICK4;
XG2:=DRAWICON(CROSS(BIAS13,REF(BIAS13,1)),BIAS13,1);
DRAWTEXT(FILTER(XG2=1,5),LOW-0.03,'ㄉ进场'),COLORYELLOW;
STICKLINE(XG2,O,C,2,0),COLOR00FFFF;
{牛熊}
NX:=MA(C,100);
牛熊:NX,COLORFFFFFF,LINETHICK1;
DRAWTEXT(ISLASTBAR,NX,' 牛熊')COLORFFFFFF;
短趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,60),2),2),2),2),LINETHICK1,COLORRED;
DRAWTEXT(ISLASTBAR,短趋势,' 短期')COLORRED;
{下面表述的所属行业、地域、板块}
DRAWTEXT_FIX(ISLASTBAR,0.00,0.0,0,DYBLOCK),COLORRED;{地域}
DRAWTEXT_FIX(ISLASTBAR,0.07,0.00,01,HYBLOCK),COLORYELLOW;{产业}
DRAWTEXT_FIX(1,0.09,0.00,0,EXTERNSTR(0,1))COLORGREEN;{详细业务}
DRAWTEXT_FIX(1,0.00,0.04,0,'主题概念:')COLORFF00FF;
DRAWTEXT_FIX(1,0.04,0.04,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.08,0,'公司亮点:')COLOR00FF00;
DRAWTEXT_FIX(1,0.04,0.08,0,EXTERNSTR(0,3))COLOR00FF00;
{显示年月日}
N11:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y:=STRCAT(CON2STR(MONTH,0),' 月 ');
R:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ:=STRCAT(STRCAT(N11,Y), R);
DRAWTEXT_FIX(C>0,0.78,0.01,0,SJ);
DRAWTEXT_FIX(1,0.01,1,0,'~★~吉星高照~★~'),COLORRED;
{波段操作解盘原码}{}
{STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0),COLOR8080FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3.1,0),COLOR000033;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0),COLOR0000CC;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0),COLORCC66FF;{立体红颜色};
{STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORFFFF00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0),COLORFF6600;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORDDDD00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0),COLORFFFF00;{立体青色};
均价:=(3*C+H+L+O)/6;
VAR1A:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2A:=(LLV(VAR1A,2)+LLV(VAR1A,4)+LLV(VAR1A,6))/3;
SZ1:=REF(VAR1A,1)=REF(VAR2A,1) AND VAR1A>VAR2A AND CLOSE>VAR1A;
SZ2:=VAR1A>VAR2A AND VAR1A>REF(VAR1A,1) AND VAR2A>REF(VAR2A,1) AND H/VAR1A<1.1 AND L>VAR2A AND CLOSE>VAR1A;
SZ3:=VAR1A>VAR2A AND VAR1A>REF(VAR1A,1) AND VAR2A>=REF(VAR2A,1) AND H/VAR1A>1.1;
SZ4:=VAR1A>VAR2A AND VAR1A>REF(VAR1A,1) AND VAR2A>REF(VAR2A,1) AND CLOSE>VAR2A AND CLOSE<VAR1A;
SZ5:=(VAR1A>VAR2A AND VAR2A>REF(VAR2A,1) AND VAR1A<>REF(VAR1A,1) AND CLOSE<VAR2A) OR (VAR1>VAR2A AND VAR1A<REF(VAR1A,1) AND VAR2A<REF(VAR2A,1) AND CLOSE<VAR2A);
SZ6:=REF(VAR1A,1)>REF(VAR2A,1) AND VAR1A=VAR2A AND CLOSE<VAR2A;
XD1:=VAR1=VAR2A AND CLOSE<VAR2A OR (VAR1A<REF(VAR1A,1) AND VAR2A<REF(VAR2A,1) AND REF(VAR1A,1)=REF(VAR2A,1) AND CLOSE<VAR2A);
XD2:=VAR1=VAR2A AND CLOSE>VAR1A;
{SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));}
{量能饱和度:=IF(SAT>1,1,SAT)*100;}
DRAWTEXT_FIX(BARSTATUS=2 AND SZ1,0.65,0.05,0,'调整结束短线介入'),COLORFF00FF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ2,0.65,0.05,0,'上升通道走势良好'),COLORRED;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ3,0.65,0.05,0,'股价偏离注意调整'),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ4,0.65,0.05,0,'上升通道调整洗盘'),COLORFFFFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ5,0.65,0.05,0,'转向特征注意离场'),COLORFF9933;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ6,0.65,0.05,0,'通道改变坚决离场'),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD1,0.72,0.05,0,'下跌通道只宜观望'),COLOR00FF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD2,0.65,0.05,0,'短期底部准备进入'),COLORYELLOW;
{DRAWTEXT_FIX(1,0.00,0.15,0,EXTERNSTR(0,1)),COLORFFFFFF; }
DRAWTEXT_FIX(1,0.48,0.05,0,'红带持股-----蓝线持币')COLORRED,LINETHICK2;
DRAWTEXT_FIX(1,0.1,1,0,'守则:1、跟踪红彩带、牛熊线走平及向上股!2、在牛熊线走平或上翘时要关注。3、下跌蓝线时不要买股!')COLORYELLOW; {0.5=X坐标;0.06=Y坐标};
{逃顶}{}
LCC:=REF(CLOSE,1);
RSIC:=SMA(MAX(CLOSE-LCC,0),6,1)/SMA(ABS(CLOSE-LCC),6,1)*100;
DRAWTEXT(CROSS(84,RSIC) , HIGH*0.99,' 逃顶'),COLORGREEN;
{绝顶逃}
日:=150;
昨前:=3;
高1:=REF(HHV(H,日),昨前);
天顶:REFDATE(高1,DATE)NODRAW,COLORCYAN;
顶:=REFDATE(高1,DATE);
极顶:=REFDATE(顶,DATE);
跑:=极顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O));
STICKLINE(跑,C,O,3,0),COLORGREEN;
STICKLINE(跑,L,H,0.1,0),COLORGREEN;
DRAWTEXT(跑,H*0.96,'---绝顶跑')COLORGREEN;
{涨跌停}
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORMAGENTA;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORWHITE;
{顶底背离,无未来}
TC1:=IF(H=HHV(H,48),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER1:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,48),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER1:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LOWER1;{低点定位}
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER1;{高点定位}
DRAWTEXT(LP,L*1,'底背'),COLORYELLOW;{波段底文字提示,黄色}
DRAWTEXT(HP,H*0.98,' 波段顶'),COLOR00FF00;{波段顶文字提示,绿色};
选股票看什么指标最好 >股票指标网