通达信时间黄金分割主图指标公式
更多金钻指标免费QQ群:39652085 指标改选股QQ群:220302856

高点:=15;
低点:=10;
时间:=1;
价格:=1;
前期高点:=C/HHV(H,120);
近期高点:=C/HHV(H,21);
PURC:=CONst(FINDHIGH(H,0,高点*10,1));
PLZ:=CONST(BArslAST(PURC=H))+1;
顶X:=CONST(IF(PLZ=1,H,REF(H,PLZ-1)));
QQT:=CONST(FINDLOW(L,0,低点*10,1));
PLL:=CONST(BARSLAST(QQT=L))+1;
低X:=CONST(IF(PLL=1,L,REF(L,PLL-1)));
AAZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-Abs(PLZ-PLL)*0.809),DRAWNULL);
ABZ:=ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.5);
acZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.618),DRAWNULL);
ADZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.382),DRAWNULL);
AEZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.236),DRAWNULL);
AFZ:=ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1);
AGZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.809),DRAWNULL);
AHZ:=ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.5);
AIZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.618),DRAWNULL);
AJZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.382),DRAWNULL);
AKZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.236),DRAWNULL);
ALZ:=ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2);
AMZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.236),DRAWNULL);
ANZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.382),DRAWNULL);
aoZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.5),DRAWNULL);
APZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.618),DRAWNULL);
AQZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.809),DRAWNULL);
ARZ:=IF(时间=1,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*3),DRAWNULL);
ASZ:=ROUND(IF(PLZ>PLL,PLZ,PLL));
{时间黄金分割处画竖线指标}
STICKLINE(CURRBARSCOUNT=AAZ,顶X,低X,0,0),COLORmaGENTA;
STICKLINE(CURRBARSCOUNT=ABZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ACZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ADZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AEZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AFZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AGZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AHZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AIZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AJZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AKZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ALZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AMZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ANZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AOZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=APZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=AQZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ARZ,顶X,低X,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=ASZ,顶X,低X,0,0),COLORMAGENTA;
QAZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1/8),DRAWNULL);
QBZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2/8),DRAWNULL);
QCZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*3/8),DRAWNULL);
QDZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*4/3),DRAWNULL);
QEZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*5/8),DRAWNULL);
QGZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*6/8),DRAWNULL);
QHZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*7/8),DRAWNULL);
QIZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*9/8),DRAWNULL);
QJZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1/3),DRAWNULL);
QKZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2/3),DRAWNULL);
QMZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*10/8),DRAWNULL);
QNZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*11/8),DRAWNULL);
QOZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*5/3),DRAWNULL);
QPZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*13/8),DRAWNULL);
QQZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*14/8),DRAWNULL);
QRZ:=IF(时间=2,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*15/8),DRAWNULL);
{标注时间黄金分割位}
BCVB:DRAWTEXT(CURRBARSCOUNT=AAZ,顶X*0.98,'0.809')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ABZ,顶X*0.98,'0.500')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ACZ,顶X*0.98,'0.618')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ADZ,顶X*0.98,'0.382')COLORMAGENTA;
DGDGV:DRAWTEXT(CURRBARSCOUNT=AEZ,顶X*0.98,'0.236')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AFZ,顶X*0.98,'1.00')COLORMAGENTA;
VFBVBV:DRAWTEXT(CURRBARSCOUNT=AGZ,顶X*0.98,'1.809')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AHZ,顶X*0.98,'1.500')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AIZ,顶X*0.98,'1.618')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AJZ,顶X*0.98,'1.382')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AKZ,顶X*0.98,'1.236')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ALZ,顶X*0.98,'2.00')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AMZ,顶X*0.98,'2.236')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ANZ,顶X*0.98,'2.382')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AOZ,顶X*0.98,'2.500')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=APZ,顶X*0.98,'2.618')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=AQZ,顶X*0.98,'2.809')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=ARZ,顶X*0.98,'3.00')COLORMAGENTA;


选股票看什么指标最好 >股票指标网